Google Cloud Global Outage - Services Operating on Fallback Providers
Resolved·Degraded performance

All Google Cloud Platform services used by StudyFetch have been restored and are operating normally. The site is fully functional.

Thank you for your patience during this incident.

Thu, Jun 12, 2025, 11:04 PM
(2 days ago)
·
Affected components
StudyFetch.com
StudyFetch Mobile App
Updates

Resolved

All Google Cloud Platform services used by StudyFetch have been restored and are operating normally. The site is fully functional.

Thank you for your patience during this incident.

Thu, Jun 12, 2025, 11:04 PM

Monitoring

We are aware of a major worldwide outage affecting Google Cloud Platform services, impacting numerous websites globally including many major platforms.

Our team has switched all AI models and Google-dependent services to our fallback service providers. Initial monitoring indicates our site remains fully functional with all critical services operational through alternative infrastructure.

We are actively monitoring the situation and will continue operating on fallback systems until Google Cloud services are fully restored and verified stable. No customer impact has been detected at this time.

We will provide updates as the situation develops

Enterprise single tenant clients are not affected by this outage.

Thu, Jun 12, 2025, 08:21 PM(2 hours earlier)
Powered by