Document Upload Issue
Resolved·Degraded performance

The document upload issue has been fully resolved. All upload functionality is operating normally and users can upload PowerPoints, PDFs, videos, and other course materials without any issues.

Our monitoring has confirmed stable performance across all upload services. Thank you for your patience during this incident.

Note: Enterprise single tenant instance clients were not affected by this issue.

Thu, Jul 3, 2025, 07:15 PM
(1 month ago)
·
Affected components
StudyFetch.com
StudyFetch Mobile App
Updates

Resolved

The document upload issue has been fully resolved. All upload functionality is operating normally and users can upload PowerPoints, PDFs, videos, and other course materials without any issues.

Our monitoring has confirmed stable performance across all upload services. Thank you for your patience during this incident.

Note: Enterprise single tenant instance clients were not affected by this issue.

Thu, Jul 3, 2025, 07:15 PM

Monitoring

A fix has been deployed to resolve the document upload issue. All upload functionality has been restored and users should now be able to upload PowerPoints, PDFs, videos, and other course materials normally.

We are actively monitoring the system to ensure stability and verify that all upload services remain fully operational. Initial testing shows successful uploads across all supported file types.

Note: Enterprise single tenant instance clients were not affected by this issue.

We will continue monitoring for the next hour to confirm complete resolution. Thank you for your patience.

Thu, Jul 3, 2025, 07:00 PM(14 minutes earlier)

Monitoring

We are currently investigating an issue affecting new document uploads on the StudyFetch platform. Users may experience errors or delays when attempting to upload PowerPoints, PDFs, videos, or other course materials.

Impact:

  • New document uploads may fail or timeout

  • Existing documents and all other platform features remain fully functional

  • AI tutoring, quizzes, flashcards, and study tools continue to work normally for previously uploaded materials

Note: Enterprise single tenant instance clients are not affected by this issue.

Our engineering team is actively working to identify and resolve the root cause. We apologize for any inconvenience and will provide updates as soon as we have more information.

Thu, Jul 3, 2025, 06:59 PM
Powered by