Site Performance Degraded
Resolved·Partial outage

Resolved.

Wed, Oct 1, 2025, 07:14 AM
(1 month ago)
·
Affected components
StudyFetch.com
StudyFetch Mobile App
Updates

Resolved

Resolved.

Wed, Oct 1, 2025, 07:14 AM

Monitoring

Incident has been resolved

Wed, Oct 1, 2025, 07:11 AM

Monitoring

We've implemented a fix and are monitoring performance as it returns to normal.

Wed, Oct 1, 2025, 06:53 AM(17 minutes earlier)

Investigating

Investigating site wide performance degradation.

Wed, Oct 1, 2025, 06:26 AM(27 minutes earlier)

Investigating

Usage of the StudyFetch site is degraded and load times are slow, we are working on a resolution.

Wed, Oct 1, 2025, 06:25 AM
Powered by