Hosting Service Disruption
Resolved·Degraded performance

All services have fully recovered following the AWS outage. Everything is operating normally.

Mon, Oct 20, 2025, 09:41 AM
(1 week ago)
·
Affected components
StudyFetch.com
StudyFetch Mobile App
StudyFetch Enterprise
StudyFetch API
Updates

Resolved

All services have fully recovered following the AWS outage. Everything is operating normally.

Mon, Oct 20, 2025, 09:41 AM

Identified

We've identified the root cause as an AWS outage affecting Vercel and our lecture recording services. Intermittent errors continue across multiple services while we await AWS resolution.

Mon, Oct 20, 2025, 08:02 AM(1 hour earlier)

Identified

We're experiencing intermittent errors due to increased internal server errors on Vercel's platform. The site remains accessible but some requests may fail.

Mon, Oct 20, 2025, 07:46 AM(15 minutes earlier)
Powered by