Resolved
We have been monitoring performance and metrics have returned to normal. Please contact support if you encounter any issues with our new update!
Identified
We have released a new update which is degrading performance on Chat, Uploads, and StudyPlans. We are working to resolve the issue.