Resolved
StudyFetch 3.0 is live and everything is operating normally. Thanks for your patience — go take a look.
Identified
StudyFetch 3.0 is live and everything is operating normally. Thanks for your patience — go take a look.
Identified
StudyFetch 3.0 is live and everything is operating normally. Thanks for your patience — go take a look.
Identified
We're rolling out StudyFetch 3.0, a full platform overhaul and rebrand. We expect no disruption, but we're opening this incident proactively because the release touches every part of the platform.
Window: roughly 30 minutes. If you do hit something, it'll most likely be a slow page load or a one-off error that clears on refresh. We'll post updates here as the rollout progresses.