Resolved
Stuck document uploads have caught up and are operating normally. This incident is resolved.
Monitoring
Stuck uploads are recovering and will be fully caught up within a few minutes. We are still actively monitoring progress closely
Monitoring
We’ve identified the issue with document uploads and implemented a fix. Processing is recovering and may take a few minutes while we monitor progress.
Investigating
Document uploads are currently delayed or failing. We are aware of the issue and are investigating the cause.